Navegando neste Tópico:   1 usuários anônimos





VTUN Cai a conexão assim que começa a transmissão de dados
Just popping in
Cadastrado em:
24/7 16:35
De UNAÍ
Grupo:
Registered Users
Mensagens: 3
Offline
Venho pedir ajuda aos colegas, sobre esse assunto, encontrei tópico anterior de erro do VTUN mas é muito antigo, e não retrata meu problema. Tenho o seguinte cenário: Servidor rodando CentOS release 5.11, vtun-3.0.2-1 com Llzo-2.06-1, atualmente já configurado e rodando 5 Túneis, Servidor VPN Cliente: CentOS release 6.9, vtun-3.0.2-1, lzo-2.06-1, no entanto ao tentar acrescentar mais 2 túneis em cidades diferentes, o túnel chega a carregar nas duas pontas(Servidor e Cliente) só que ao iniciar o tráfego de pacotes, o mesmo cai e não deixa nenhum erro pelo menos aparente. Já Busquei em vários artigos e nenhum resolver.

Enviado em: 24/7 16:52
Transferir mensagem para outros aplicativos Transferir


Re: VTUN Cai a conexão assim que começa a transmissão de dados
Home away from home
Cadastrado em:
14/2/2012 20:37
De Belo Horizonte MG
Grupo:
Registered Users
Mensagens: 684
Offline
Tenta subir o tunel sem o lzo.

Enviado em: 30/7 10:11
Transferir mensagem para outros aplicativos Transferir


Re: VTUN Cai a conexão assim que começa a transmissão de dados
Just popping in
Cadastrado em:
24/7 16:35
De UNAÍ
Grupo:
Registered Users
Mensagens: 3
Offline
by Estefanio Brunhara em 30-07-2017 10:11:26

Tenta subir o tunel sem o lzo.

Agradeço a resposta, mas fiquei na dúvida, executar sem o lzo somente no cliente? poderia me dar um exemplo?Citando:

Estefanio Brunhara escreveu:
Tenta subir o tunel sem o lzo.

Enviado em: 27/9 14:23
Transferir mensagem para outros aplicativos Transferir


Re: VTUN Cai a conexão assim que começa a transmissão de dados
Just popping in
Cadastrado em:
24/7 16:35
De UNAÍ
Grupo:
Registered Users
Mensagens: 3
Offline
Citando:

WENDELL ALMEIDA escreveu:
by Estefanio Brunhara em 30-07-2017 10:11:26

Tenta subir o tunel sem o lzo.

Agradeço a resposta, mas fiquei na dúvida, executar sem o lzo somente no cliente? poderia me dar um exemplo?Citando:

Estefanio Brunhara escreveu:
Tenta subir o tunel sem o lzo.


Seguindo sua idéia retirei as configurações do lzo do conf do vtun tanto no servidor como no cliente, e o problema permanece, como pode observar abaixo o log no servidor matriz da VPN o tunel sobe, mas ao tentar pingar na outra ponta, ou seja tráfego cai imediatamente:

[Log do var/log/messages do servidor da VPN]
Sep 27 14:41:40 localhost vtund[31612]: VTUN server ver 3.X 02/10/2008 (stand)
Sep 27 14:41:48 localhost avahi-daemon[2481]: Invalid query packet.
Sep 27 14:42:18 localhost last message repeated 7 times
Sep 27 14:42:18 localhost vtund[31614]: Session cristalina[189.85.81.228:40961] opened
Sep 27 14:42:18 localhost kernel: tun5: Disabled Privacy Extensions
Sep 27 14:42:19 localhost vtund[31614]: UDP connection initialized
Sep 27 14:42:19 localhost vtund[31614]: LZO compression[level 1] initialized
Sep 27 14:42:19 localhost vtund[31614]: Blowfish-128-ECB encryption initialized
Sep 27 14:43:16 localhost avahi-daemon[2481]: Invalid query packet.
Sep 27 14:43:17 localhost last message repeated 3 times
Sep 27 14:43:20 localhost vtund[31614]: Connection refused (111)
Sep 27 14:43:20 localhost vtund[31614]: Session cristalina closed

[LOG DO /var/log/messages do Cliente]
Sep 27 14:29:49 localhost vtund[8519]: VTUN server ver 3.X 11/12/2010 (stand)
Sep 27 14:33:29 localhost vtund[8591]: VTun client ver 3.X 11/12/2010 started
Sep 27 14:33:29 localhost vtund[8591]: Connecting to 177.72.56.163
Sep 27 14:33:29 localhost vtund[8591]: Session cristalina[177.72.56.163] opened
Sep 27 14:33:29 localhost vtund[8591]: UDP connection initialized
Sep 27 14:33:29 localhost vtund[8591]: LZO compression[level 1] initialized
Sep 27 14:33:29 localhost vtund[8591]: Blowfish-128-ECB encryption initialized
Sep 27 14:34:30 localhost kernel: vtund[8591]: segfault at 40 ip 0000000000409e86 sp 00007fffee452720 error 4 in vtund[400000+12000]
Sep 27 14:34:30 localhost abrt[8619]: Saved core dump of pid 8591 (/usr/sbin/vtund) to /var/spool/abrt/ccpp-2017-09-27-14:34:30-8591 (823296 bytes)
Sep 27 14:38:36 localhost vtund[8519]: Terminated

Enviado em: 27/9 14:46
Transferir mensagem para outros aplicativos Transferir


Re: VTUN Cai a conexão assim que começa a transmissão de dados
Home away from home
Cadastrado em:
14/2/2012 20:37
De Belo Horizonte MG
Grupo:
Registered Users
Mensagens: 684
Offline
Você esta com prob no VTUN e o Lzo, certo? O lzo é para compactar o trafego do tunel, então você tem 2 software trabalhando junto, se você tem um problema, melhor fazer teste usando somente o vtun.

Isto ajuda no cerco do problema. vc deve desativar o lzo nas duas pontas onde você esta tendo problema.

Enviado em: 9/10 8:51
Transferir mensagem para outros aplicativos Transferir






Você pode exibir os tópicos.
Você não pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Pesquisa Avançada]