Navegando neste Tópico:   1 usuários anônimos





Problemas com partições lvm
Just popping in
Cadastrado em:
28/11/2010 12:43
De São Paulo
Grupo:
Registered Users
Mensagens: 6
Offline
Bom dia.
Tenho um servidor de arquivos com 2 volume groups, um pro so, que possui 2 discos fisicos com a partição / e uma partição swap e chamarei de vg1, e um para o compartilhamento com 2 discos fisicos e uma única partição ext4 que chamarei de vg2.
Ao tentar de forma frustrada instalar o centos5 neste servidor, eu acidentalmente, corrompi o um dos discos do vg2 e agora não consigo mais montar o vg2 pois o mesmo me informa que não encontra o segundo disco.
Ao tentar recuperar o disco corrompido, o testdisk me informa que tem uma partição do tipo lvm e a mesma está intácta e, o fdisk me dis o mesmo.
Alguém sabe alguma forma de recuperar esse disco e os dados que estão nele?

Enviado em: 28/11/2010 12:53

Editado por Rodrigo Baldasso em 28-11-2010 16:27:56
Transferir mensagem para outros aplicativos Transferir


Re: Problemas com partições lvm
Just popping in
Cadastrado em:
11/12/2009 15:27
De Fortaleza
Grupo:
Registered Users
Mensagens: 2
Offline
Olá,

Há primeira coisa que você tem que deixar clara e qual o sistema de arquivos que está rodando nessa partição em lvm que deu problema.
Se for ext4 como parece ser, você vai usar o fsck para tentar recuperar esse disco.
Geralmente se usa em lvm o XFS que pode ser executado com o sistema on-line, ou seja, com a partição montada.
Se for o seu caso, tente usar o xfs_repair para recuperar a sua partição.

Vai alguns links que me ajudaram quando precisei recuperar uma partição em XFS:

http://linux.die.net/man/8/xfs_repair
http://wiki.sj.cefetsc.edu.br/wiki/in ... e_parti%C3%A7%C3%B5es_LVM

Enviado em: 30/11/2010 10:18
Transferir mensagem para outros aplicativos Transferir


Re: Problemas com partições lvm
Just popping in
Cadastrado em:
28/11/2010 12:43
De São Paulo
Grupo:
Registered Users
Mensagens: 6
Offline
Opa Roberto, tudo bem?
Na verdade meu filesystem é o ext4 mas, como o desespero é grande eu executei o comando que você comentou o xfs_repair e, teve a seguinte saida:
.........Sorrycould not find valid secondary superblock
Exiting now
.


Quando rodo o fsck.ext4 dá o seguinte retorno:

su -'fsck.ext4 -b 8193 /dev/sdb1'
Password
e2fsck 1.41.12 (17-May-2010)
fsck.ext4Bad magic number in super-block while trying to open /dev/sdb1

The superblock could not be read 
or does not describe a correct ext2
filesystem
.  If the device is valid and it really contains an ext2
filesystem 
(and not swap or ufs or something else), then the superblock
is corrupt
, and you might try running e2fsck with an alternate superblock:
    
e2fsck -b 8193 <device>


Tem algum a idéia companheiro?

Enviado em: 5/12/2010 20:26
Transferir mensagem para outros aplicativos Transferir


Re: Problemas com partições lvm
Home away from home
Cadastrado em:
19/4 3:00
De Tbilisi
Grupo:
Registered Users
Mensagens: 3289
Offline

Enviado em: 20/4 19:12
Transferir mensagem para outros aplicativos Transferir






Você pode exibir os tópicos.
Você não pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Pesquisa Avançada]