Navegando neste Tópico:   1 usuários anônimos





Problema de dependência na instalação do mplayer
Just popping in
Cadastrado em:
13/7/2010 9:48
De Uberlândia
Grupo:
Registered Users
Mensagens: 6
Offline
Não consigo ouvir mp3 e muito menos ver videos no CentOs 5. Pesquisei na internet e achei o mplayer como uma das opções mas depois de várias tentativas de instalação aparece esse erro abaixo:

mplayer-1.0-0.43.svn20090711.el5.rf.i386 from rpmforge has depsolving problems
  
--> Missing DependencylibXvMCW.so.1 is needed by package mplayer-1.0-0.43.svn20090711.el5.rf.i386 (rpmforge)
ErrorMissing DependencylibXvMCW.so.1 is needed by package mplayer-1.0-0.43.svn20090711.el5.rf.i386 (rpmforge)
ErrorMissing DependencylibXvMC.so.1 is needed by package mplayer-1.0-0.43.svn20090711.el5.rf.i386 (rpmforge)
ErrorMissing Dependencylibglut.so.3 is needed by package libcaca-0.99-0.1.beta17.el5.rf.i386 (rpmforge)
 
You could try using --skip-broken to work around the problem
 You could 
try runningpackage-cleanup --problems
                        package
-cleanup --dupes
                        rpm 
-Va --nofiles --nodigest


Como resolver esse problema de dependência?

Enviado em: 2/8/2010 10:46
Transferir mensagem para outros aplicativos Transferir


Re: Problema de dependência na instalação do mplayer
Just can't stay away
Cadastrado em:
29/4/2009 13:48
De Goiânia
Grupo:
Registered Users
Mensagens: 95
Offline
Instale os repositorios extras (RpmForge, Plus e Extras): http://wiki.centos.org/AdditionalResources/Repositories

E bom tb dar uma olhada nesse guia de multimedia para o CentOS: http://wiki.centos.org/TipsAndTricks/MultimediaOnCentOS

[]´s

Enviado em: 2/8/2010 14:24
Transferir mensagem para outros aplicativos Transferir


Re: Problema de dependência na instalação do mplayer
Just popping in
Cadastrado em:
13/7/2010 9:48
De Uberlândia
Grupo:
Registered Users
Mensagens: 6
Offline
Adicionei mas 2 repositorios mas ainda estou com problema de depedência, a lista de repositorios está abaixo:

[base]
name=CentOS-Base
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=os
#baseurl=http://mirror.centos.org/centos/5/os/i386/
gpgcheck=1
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled 0

#released updates
[updates]
name=CentOS-Updates
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=updates
#baseurl=http://mirror.centos.org/centos/5/updates/i386/
gpgcheck=1
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#packages used/produced in the build but not released
[addons]
name=CentOS-Addons
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=addons
#baseurl=http://mirror.centos.org/centos/5/addons/i386/
gpgcheck=1
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled 0

#additional packages that may be useful
[extras]
name=CentOS-Extras
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=extras
#baseurl=http://mirror.centos.org/centos/5/extras/i386/
gpgcheck=1
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
enabled 0


#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-Plus
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=centosplus
#baseurl=http://mirror.centos.org/centos/5/centosplus/i386/
gpgcheck=1
enabled
=0
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#contrib - packages by Centos Users
[contrib]
name=CentOS-Contrib
mirrorlist
=http://mirrorlist.centos.org/?release=5&arch=i386&repo=contrib
#baseurl=http://mirror.centos.org/centos/5/contrib/i386/
gpgcheck=1
enabled
=0
gpgkey
=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

[kbs-CentOS-Extras]
name=CentOS.Karan.Org-EL$releasever Stable
gpgcheck
=1
gpgkey
=http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
enabled=1
baseurl
=http://centos.karan.org/el$releasever/extras/stable/$basearch/RPMS/

[kbs-CentOS-Misc]
name=CentOS.Karan.Org-EL$releasever Stable
gpgkey
=http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
gpgcheck=1
enabled
=1
baseurl
=http://centos.karan.org/el$releasever/misc/stable/$basearch/RPMS/


Dependências:
1:openoffice.org-core-3.1.1-19.5.el5_5.1.i386 from updates has depsolving problems
  
--> Missing Dependencylucene is needed by package 1:openoffice.org-core-3.1.1-19.5.el5_5.1.i386 (updates)
1:cups-1.3.7-18.el5_5.4.i386 from updates has depsolving problems
  
--> Missing Dependencypoppler-utils is needed by package 1:cups-1.3.7-18.el5_5.4.i386 (updates)
ErrorMissing Dependencylucene is needed by package 1:openoffice.org-core-3.1.1-19.5.el5_5.1.i386 (updates)
ErrorMissing Dependencypoppler-utils is needed by package 1:cups-1.3.7-18.el5_5.4.i386 (updates)


Sobre o mplayer ainda não consigo fazer nada:
root@Dmae yum.repos.d]# yum info mplayer
Loaded pluginsfastestmirror
Loading mirror speeds from cached hostfile
 
rpmforgefr2.rpmfind.net
 
updatescentos.pop.com.br
Available Packages
Name       
mplayer
Arch       
i386
Version    
1.0
Release    
0.43.svn20090711.el5.rf
Size       
5.2 M
Repo       
rpmforge
Summary    
MPlayerthe Movie Player for Linux
URL        
http://mplayerhq.hu/


Enviado em: 2/8/2010 17:16
Transferir mensagem para outros aplicativos Transferir






Você pode exibir os tópicos.
Você não pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Pesquisa Avançada]